Resolved
Unable to purchase Business plan

Started
January 04, 2023 at 3:17 AM
Status
Resolved after about 5 hours

Impact

Operational
  • Resolved

    Users trying to purchase the business plan will see an incorrect price and be charged for the HIPAA business plan.