Resolved
Contact form is broken

Started
May 03, 2023 at 10:14 PM
Status
Resolved after about 3 hours

Impact

Degraded performance
Affected
Website
  • Resolved

    We have temporarily removed our contact form since the problem is with an upstream provider. Users are advised to contact us directly in the meantime.

  • Investigating

    The contact form on our website errors when users try to send an email to us. Please use our Slack community or email us at hello@dovetailapp.com directly instead.