Resolved
Contact form is broken

Started
May 19, 2023 at 6:39 AM
Status
Resolved after about 1 hour

Impact

Operational
Affected
Website
  • Resolved

    This incident has been resolved.

  • Identified

    We have determined a fix for the incident, and are deploying the changes now.

  • Investigating

    We are currently investigating this incident. In the meantime, please email us at hello@dovetailapp.com if you would like to contact us.