Dovetail currently unavailable

Resolved
Major outage
Started over 1 year ago Lasted about 1 hour

Affected

Core
Core - USA
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We have identified and fixed the issue, we are continuing to monitor the situation

  • Investigating
    Investigating

    Dovetail is currently unavailable. We are currently investigating the issue.