Some users may not be able to SSO

Resolved
Degraded performance
Started almost 2 years ago Lasted 24 minutes

Affected

Authentication
Authentication - USA
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    As some SSO providers use CloudFlare which is currently experiencing an outage, you may not be able to log in.