Emails temporarily unavailable

Resolved
Degraded performance
Started almost 2 years ago Lasted about 2 hours

Affected

AWS
Emails
Authentication
Authentication - USA
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Update

    We are continuing to monitor for any further issues.

  • Monitoring
    Monitoring

    A fix has been implemented and we are monitoring the results.

  • Identified
    Identified

    Due to an upstream provider issue, Dovetail currently can not send outbound emails. This effects sharing, invites and new sign up email verification. We are working with our provider to solve this issue.