Minor issues with interactions on Safari
Incident Report for Dovetail
Resolved
This incident has been resolved.
Posted Aug 09, 2021 - 16:47 AEST
Monitoring
A fix as been implemented and we're monitoring the results
Posted Aug 09, 2021 - 12:52 AEST
Investigating
Some Safari users might be experiencing unstable click interactions across Dovetail. We are actively investigating the issue and hope to have a resolution released shortly.
Posted Aug 09, 2021 - 08:49 AEST