Dovetail currently unavailable
Incident Report for Dovetail
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 21:14 AEDT
Monitoring
We have identified and fixed the issue, we are continuing to monitor the situation
Posted Nov 17, 2022 - 20:32 AEDT
Investigating
Dovetail is currently unavailable. We are currently investigating the issue.
Posted Nov 17, 2022 - 20:25 AEDT
This incident affected: Core (Core - USA).