Minor Billing Issue
Incident Report for Dovetail
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 13:45 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2021 - 12:41 AEDT
Identified
We have identified an issue affecting a small portion of customers attempting to access the billing section of the product. We are actively working on a fix and will keep this incident updated with the latest information.
Posted Jan 13, 2021 - 09:45 AEDT
This incident affected: Billing & payments (Stripe).