Issues with Zoom imports, Google imports and Unsplash cover photos
Incident Report for Dovetail
Resolved
A fix has been implemented a fix and are monitoring the results
Posted Jul 25, 2022 - 14:03 AEST
Investigating
We are investigating reports of issues with Zoom imports, Google imports, and Unsplash cover photos.
Posted Jul 25, 2022 - 13:33 AEST
This incident affected: Core.